Перейти к содержимому


GimpLensfun для Mac OS


Сообщений в теме: 5

#1 Sergii

  • Пользователь
  • 5 283 сообщений
  • Город:Киев

Отправлено 05 Февраль 2020 - 13:07

Коллеги-маководы! Кому-то удалось привязать к GIMP плагин Lensfun (https://seebk.github.io/GIMP-Lensfun/)? Если да, поделитесь опытом. Сам плагин, через терминал в систему установил. Но GIMP его не видит. В его настройках каталоги прописывал, всё бесполезно. В документации написано, "инсталлируйте и пользуйтесь". А как пользоваться, непонятно.

#2 scorta

  • Пользователь
  • 2 226 сообщений

Отправлено 05 Февраль 2020 - 13:18

Каталоги, куда можно устанавливать плагины можно посмотреть в интерфейсе:
"Edit" > "Preferences" > "Folders" > "Plug-Ins" (по-русски примерно так будет: редактирование-настройки-папки-расширения).
Сейчас под руками мака нет. Если запустить в консоли, что-нибудь видно?
Если проблема возникает во время загрузки плагина - это пишется на экран.

#3 scorta

  • Пользователь
  • 2 226 сообщений

Отправлено 05 Февраль 2020 - 13:27

Мака сейчас под руками нет. На линуксе.
Cкомпилировал из исходников. Положил исполняемый файл, который собрался в результате в домашний каталог плагинов.
~/.config/GIMP/2.10/plug-ins/gimp-lensfun

Всё получилось.

Сообщение отредактировал scorta: 05 Февраль 2020 - 13:27


#4 Sergii

  • Пользователь
  • 5 283 сообщений
  • Город:Киев

Отправлено 05 Февраль 2020 - 13:50

Просмотр сообщенияscorta (05 Февраль 2020 - 13:18) писал:

Каталоги, куда можно устанавливать плагины можно посмотреть в интерфейсе:
"Edit" > "Preferences" > "Folders" > "Plug-Ins"
К сожалению, это не работает. После установки получилась папка с файлами (/usr/local/cellar/lensfun/0.3.95_1), в которой, в свою очередь, 4 папки (bin, include, lib, share). Ни в самой директории, ни в упомянутых папках нет файлов, которые GIMP определил бы как плагин. Похоже, я делаю что-то не так. Устанавливал по этой инструкции http://macappstore.org/lensfun/

Сообщение отредактировал Sergii: 05 Февраль 2020 - 13:54


#5 scorta

  • Пользователь
  • 2 226 сообщений

Отправлено 05 Февраль 2020 - 14:04

Кажется начинаю понимать. По номеру я вижу, что вы говорите о библиотеке lensfun (0.3.95_1).
Её местоположение - это обычное место для библиотек (попробуйте через brew, он сам положит куда нужно).
Чтобы запускать из гимпа этого недостаточно, нужен еще один компонент, сам плагин, последняя версия - 0.2.4.
Так вот то, что я писал относится к плагину - это один файл с аттрибутом исполнения (chmod +x ), который идёт в каталог плагинов.

#6 Sergii

  • Пользователь
  • 5 283 сообщений
  • Город:Киев

Отправлено 05 Февраль 2020 - 21:35

Просмотр сообщенияscorta (05 Февраль 2020 - 14:04) писал:

Кажется начинаю понимать. По номеру я вижу, что вы говорите о библиотеке lensfun (0.3.95_1).
Её местоположение - это обычное место для библиотек (попробуйте через brew, он сам положит куда нужно).
Именно через brew и устанавливал.

Просмотр сообщенияscorta (05 Февраль 2020 - 14:04) писал:

нужен еще один компонент, сам плагин, последняя версия - 0.2.4.
И где же его взять? Я в ступоре! Еще раз проделал все по мануалу.
Вот скрин терминала.
Прикрепленное изображение: Снимок экрана 2020-02-05 в 20.31.58.png

И что делать дальше? Не пойму!





Количество пользователей, читающих эту тему: 1

0 пользователей, 1 гостей, 0 анонимных